Stuck at checking licence-update but license won't activate

Home Forums Software Support Call Flow Manager Stuck at checking licence-update but license won't activate

This topic contains 15 replies, has 5 voices, and was last updated by  Site Admin 9 months ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #3299

    Dustin
    Participant

    I read the article at https://mailchi.mp/4a86fea24d31/issues-starting-call-flow-manager

    I logged into my account and downloaded the latest version. I copied over all files except
    Config.dat – this contains licence information. Its best not to delete or overwrite this, or you’ll need to re-enter your licence key
    CallFlowManager.UI.exe.config – this contains application configuration. It’s best not to overwrite this so you don’t loose any configuration changes you have made

    Per the instructions at this link- https://theucguys.com/kb/article/upgrading-call-flow-manager/

    Gets past the check license but then says activation was unsuccessful. Please check your details and try again.

    I checked my API keys and verified they are correct. I verified the email is correct and the software title. In fact they were pre filled from the previous version running and not overwriting the config.dat file.

    I verified in my account that the API key is correct. I have 2 CFM4 and CFM1. I verified I copied over the CFM1 download.

    Need help not able to access product any longer and really need to update call flow for a client as soon as possible due to issues/errors

    #3301

    Site Admin
    Keymaster

    Hi

    So that I can access your account information can you please log a support ticket and provide the licence keys, of the email address used to register.

    I will delete your activations for you and see if that helps (you can also do this from the My Account area under API Keys)

    Thanks,
    Andrew

    #3304

    Dustin
    Participant

    I have already tied deleting the activation and still will not successfully activate. I am not able to log a support ticket. I have tried chrome, firefox and microsoft edge. In all cases when going to the support ticket site, this is all that I see. I can click on support forums, however, there is no link to submit a support ticket just the [wp_support_plus] which appears to be a broken link:

    Use our ticketing system to get in touch with us about anything. We aim to respond to you with 48 hours. You might also like to use our support forums.

    Our support hours are 5am – 12pm Monday to Friday (GMT/UTC timezone). Currently it’s Tuesday at 01:31pm.
    [wp_support_plus]

    #3305

    Dustin
    Participant

    As an FYI, we have 5 licenses and another customer that has their own. We are all experiencing the same issue. The support ticket link does not exist and activation is unsuccessful.

    #3306

    Mike
    Participant

    We are also having the license activation problem. System log of the server is also reporting a Schannel Error. Seems to me there’s a cipher negotiation issue. Ours is a Windows 2012 system, but we’ve used IISCrypto to clear out dead/bad ciphers, and disable 3DES, but there are plenty of other ciphers to use. Just ran a check via https://www.ssllabs.com/ssltest/analyze.html?d=theucguys.com, looks like you’ve killed supportability for IE11 unless running on Windows 10/Server 2016.

    #3308

    Site Admin
    Keymaster

    Hi guys,

    Thanks for your patience on this.

    @Mike The SSL changes on the server side certainly appear to be an issue. I did originally query this with the vendor but didn’t get an adequate response. Its certainly not anything we have changed and I am again trying to find out why we now only support TLS1.2 (a good thing but certainly not so good from a backward compatibility perspective!). The fix we released in 1.7.1 simply enabled TLS1.2 on the app side.

    @dustin Ticketing system is resolved now, apologies. I would appreciate the app logs so I can see the response we are getting from the server

    #3310

    Site Admin
    Keymaster

    Hey All,

    Our hosting provider now enforces TLS1.2 – this is a good thing and most service providers are moving to do this. Whats not good is that we were not notified about this change in advance so we could prepare for it. For that, I am very sorry and apologise for the inconvenience. Unfortunately, there is no short-term solution and we would need to move to a service provider that supports older TLS versions. In saying this, Windows Server 2008 and above should support TLS1.2 however you might need to enable it or update your server. For help on ServerTLS support see – https://blogs.technet.microsoft.com/askds/2015/12/08/speaking-in-ciphers-and-other-enigmatic-tonguesupdate/

    Windows Server Support for SSL

    Vendor statement:
    “The issue here is that we host a lot of customers that do things like running ecommerce sites. While I wish we could selectively enable less security by account – it’s an all or nothing issue. It wouldn’t be good for our clients relying on SSL for securely transmitting private, confidential, or personal data for us to allow this to happen over insecure and easily broken methods.
    To make an example – it does no good for our clients to use an unbreakable safe-door to keep their data secure – if anybody that doesn’t support that safe door can just use the plywood door right next to it.
    I am sorry that our production hosting servers cannot continue to support low-security protocols to support outdated and no-longer-supported copies of Windows – but that is never anything that we promised you that we’d be able to do.”

    #3312

    Mike
    Participant

    Problem is that your hoster isn’t using any ciphers that are supported with Windows 2012 or 2008 R2 or 2008 R1 servers. https://docs.microsoft.com/en-us/windows/desktop/secauthn/tls-cipher-suites-in-windows-8

    We do have TLS 1.2 enabled. I would say that TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384 needs to be added to your hosts cipher list, it’s the highest that 2008r2/2012/2012R2 can go to.

    Either that or have the App use a different engine such as Firefox or Chrome, as IE outside of Server2016/Win10, doesn’t support TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384

    #3313

    Site Admin
    Keymaster

    Thanks for that feedback Ill go back to them a see what they say.

    In the meantime, I will look at a failback to HTTP so we can get you guys up and running again.

    #3315

    Site Admin
    Keymaster

    We have an HTTP failback option coming soon. I hope to release in the next 24-hours. Thanks again for your patience.

    #3316

    Site Admin
    Keymaster

    We have a beta build available and would be grateful to anyone who could test and report back.

    Notes:
    – Limited testing has been completed so far and the app may crash if there are any unhandled errors
    – When the app starts it will look like its doing nothing – this is because it’s loading 1 tab at a time. If you jump through the tabs you will see which one is currently loading. Before release, this behavior will change to indicate all tabs are loading
    – There is a new setting to control the use of SSL when checking the license. By default, the use of SSL is disabled. This is because TLS1.2 with strong ciphers is enforced by the license server, and older versions of Windows will not support them

    Build available here – https://theucguys.com/downloads/CallFlowManager_UNRELEASED_v1.8.1.zip
    – Download and copy your Config.dat file over to maintain the currently entered licence info
    – Make sure you use the new CallFlowManager.UI.exe.Config file. If you have changed any settings you’ll need to copy them back over

    Thanks again for your patience.

    #3321

    Site Admin
    Keymaster

    Some bug fixes for the previously released beta – https://theucguys.com/downloads/CallFlowManager_UNRELEASED_v1.8.2.zip

    Refer to above post for beta release details

    Has anyone had a chance to test the activation fix? Any other issues found?

    • This reply was modified 9 months, 2 weeks ago by  Site Admin.
    #3325

    gillesandre.poupart
    Participant

    Hello

    I was stuck at “checking license” and it’s now working!

    Thanks a lot!

    #3326

    Site Admin
    Keymaster

    Great, thanks so much for letting us know. If you have any issues with this pre-release please post back here so we can get them resolved.

    #3330

    James
    Participant

    I am having this same issue. I tried to install CallFlowManager_UNRELEASED_v1.8.3.zip and when I ran the .exe file as an administrator, then tried to input my Email, API License Key, and software Title it will say “Activation was unsuccessful. Please Check your details and try again. I know that we have 1 license for this and in the API under my account it states 1 activation of 1. IS there a way to void out the other installation so I can install this on a different machine?

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.